Установить Магазин Snappy в дистрибутивы Linux

classic Классический list Список threaded Древовидный
19 сообщения Инструменты
Ответить | Древовидный
Открыть эту статью в виде дерева
|

Установить Магазин Snappy в дистрибутивы Linux

Админ
Администратор
Магазин Snappy — удобная программа управления программным обеспечением в системе с пакетами snap.
Snappy — система развёртки и управления пакетами, разработанная Canonical для мобильной Ubuntu. Пакет называется snap, утилита для управления — snapd, всё это работает на широком спектре дистрибутивов Linux и позволяет создавать дистрибутивно-независимые программные продукты. Система разработана для работы как для интернета вещей, для облачных решений, так и для пользовательских задач.
http://compizomania.blogspot.com/2019/02/snappy-linux.html
Ответить | Древовидный
Открыть эту статью в виде дерева
|

Re: Установить Магазин Snappy в дистрибутивы Linux

victorubuntu
не запускается в убунту 18,04,2
Ответить | Древовидный
Открыть эту статью в виде дерева
|

Re: Установить Магазин Snappy в дистрибутивы Linux

Админ
Администратор
Попробуй перезагрузиться
Ответить | Древовидный
Открыть эту статью в виде дерева
|

Re: Установить Магазин Snappy в дистрибутивы Linux

zelinograd
И в Debian9.8 не запускается даже после перезагрузки.
Ответить | Древовидный
Открыть эту статью в виде дерева
|

Re: Установить Магазин Snappy в дистрибутивы Linux

zurqwany
В ответ на это сообщение от Админ
rynych@Extensa-5220 ~ $ sudo snap install snap-store
[sudo] пароль для rynych:
sudo: snap: команда не найдена
rynych@Extensa-5220 ~ $
Сами snap из МП ставятся, Минт 18.1 Мате
Ответить | Древовидный
Открыть эту статью в виде дерева
|

Re: Установить Магазин Snappy в дистрибутивы Linux

Админ
Администратор
В ответ на это сообщение от zelinograd
Для того чтобы в Debian запустить магазин, нужно дополнительно установить пакет gnome-3-28-1804

sudo snap install gnome-3-28-1804

И первый раз запустить из терминала командой: snap-store

Ответить | Древовидный
Открыть эту статью в виде дерева
|

Re: Установить Магазин Snappy в дистрибутивы Linux

Админ
Администратор
В ответ на это сообщение от zurqwany
В Минт 18.1 Мате проверьте установлен ли пакет gnome-3-26-1604

Выполните команду snap list, которая определяет все установленные в системе snap-пакеты. Если gnome-3-26-1604 не установлен, установите его командой:
sudo snap install gnome-3-26-1604
Ответить | Древовидный
Открыть эту статью в виде дерева
|

Re: Установить Магазин Snappy в дистрибутивы Linux

zurqwany
rynych@Extensa-5220 ~ $ snap list
Программа 'snap' на данный момент не установлена. Вы можете установить её, выполнив:
sudo apt install snapd
rynych@Extensa-5220 ~ $ sudo apt install snapd
[sudo] пароль для rynych:
Чтение списков пакетов… Готово
Построение дерева зависимостей      
Чтение информации о состоянии… Готово
E: Не удалось найти пакет snapd
rynych@Extensa-5220 ~ $ sudo snap install gnome-3-26-1604
sudo: snap: команда не найдена
rynych@Extensa-5220 ~ $
Ответить | Древовидный
Открыть эту статью в виде дерева
|

Re: Установить Магазин Snappy в дистрибутивы Linux

Владимир Маслов
Это сообщение было обновлено .
В ответ на это сообщение от Админ
У меня подозрение, что у него не включены репы...

Пакет snapd находится в security и ports



Может у него не включены они...


Ответить | Древовидный
Открыть эту статью в виде дерева
|

Re: Установить Магазин Snappy в дистрибутивы Linux

Админ
Администратор
Это сообщение было обновлено .
СОДЕРЖАНИЕ УДАЛЕНО
Автор удалил это сообщение.
Ответить | Древовидный
Открыть эту статью в виде дерева
|

Re: Установить Магазин Snappy в дистрибутивы Linux

zurqwany
Всё, Вы правы, партнеров включил. Теперь работает. Хитрая штука, вроде себя как почти гуру по линю считаю, ан нет. Лузер.
Ответить | Древовидный
Открыть эту статью в виде дерева
|

Re: Установить Магазин Snappy в дистрибутивы Linux

Владимир Маслов
Гуру тоже ошибаются...

Быть семи пядей во лбу не суждено ни кому, увы!

Как говаривал Ильич: - Учиться, учиться и ещё раз учиться!
Что мы все и делаем.
Ответить | Древовидный
Открыть эту статью в виде дерева
|

Re: Установить Магазин Snappy в дистрибутивы Linux

AlexandrS
В ответ на это сообщение от Админ
В дистрибутиве Linux MX, Магазин Snappy не устанавливается. Очень даже жаль
Ответить | Древовидный
Открыть эту статью в виде дерева
|

Re: Установить Магазин Snappy в дистрибутивы Linux

GodKiller_222
Серьезно, жаль? Все это элементарно устанавливается из репозиториев или ручной сборкой. Snap - это хилая реализация контейнера для идиотов. Это Линукс, млин, здесь за 5 минут можно упаковать тяжелые вещи в отдельный контейнер (сквош лекс и т.д.) и подключать, как новое устройство, когда нужно. А тут тащится 100500 зависимостей хз кем как и когда упакованных... Дебилы, мля (с) Лавров.
Ответить | Древовидный
Открыть эту статью в виде дерева
|

Re: Установить Магазин Snappy в дистрибутивы Linux

Guns
В ответ на это сообщение от Админ
Владимир, подскажи как запустить Магазин Snappy в Solus 3,9999 GNOME 3.28 ?
Он установился, но не запускается. Я тут посмотрел, что можно поставить галочки и разрешить обновление проприетарному ПО, но у меня в Солусе нет такого меню. В Солус свой собственный Менеджер Программ и нет привычной "программное обновление". В этом ли дело?

Gnome у меня уже установлен 3.28. Что нужно тогда?
Нам обоим очень жаль.
Ответить | Древовидный
Открыть эту статью в виде дерева
|

Re: Установить Магазин Snappy в дистрибутивы Linux

Админ
Администратор
Это сообщение было обновлено .
У меня не установлена SolusOS, поэтому не могу с уверенностью сказать почему не запускается Магазин Snappy.
Одно лишь могу подсказать, что если приложение не запускается из системного меню, запустите его из терминала и вывод терминала скажет Вам, почему не запускается программа.
Запустите Магазин Snappy командой в терминале snap-store
И скиньте вывод команды в комментарий. Попробуем вместе разобраться.
Ответить | Древовидный
Открыть эту статью в виде дерева
|

Re: Установить Магазин Snappy в дистрибутивы Linux

Guns
Вот вывод команды:

snap-store
cannot change profile for the next exec call: No such file or directory
snap-update-ns failed with code 1: No such file or directory
Нам обоим очень жаль.
Ответить | Древовидный
Открыть эту статью в виде дерева
|

Re: Установить Магазин Snappy в дистрибутивы Linux

Админ
Администратор
Возможные причины.

1. Возможно Вы устанавливали новое ядро. Вернитесь к ядру по умолчанию.
2. Если первый вариант не Ваш, переустановите snapd командой:
sudo eopkg install --reinstall snapd 
3. Ещё. Перезапустите сервис snapd: systemctl enable snapd или sudo systemctl start snapd
4. Если три варианта не сработали для Вас, попробуйте создать новый профиль командой:
sudo apparmor_parser -r /var/lib/snapd/apparmor/profiles/*
Почитайте здесь: Проблемы с snapd и snap в Solus 3.9999
https://dev.getsol.us//T6499
Ответить | Древовидный
Открыть эту статью в виде дерева
|

Re: Установить Магазин Snappy в дистрибутивы Linux

Guns
Snapd у меня работает! Я установил через сайт snapcraft.io одно приложение. И оно запустилось в Solus!

А вот сам snap-store нет, пишет: execv failed: No such file or directory
Нам обоим очень жаль.