Corona-cli - отслеживание статистики коронавируса (COVID-19) из терминала Linux

classic Классический list Список threaded Древовидный
31 сообщения Инструменты
12
Ответить | Древовидный
Открыть эту статью в виде дерева
|

Corona-cli - отслеживание статистики коронавируса (COVID-19) из терминала Linux

Админ
Администратор
 Коронавирусы являются большим семейством вирусов, способных вызывать разные болезни у людей — от обычной простуды до ТОРС (тяжёлый о́стрый респирато́рный синдро́м). Вирусы из этого семейства вызывают также ряд болезней среди животных.
https://compizomania.blogspot.com/2020/03/corona-cli-covid-19-linux.html
Ответить | Древовидный
Открыть эту статью в виде дерева
|

Re: Corona-cli - отслеживание статистики коронавируса (COVID-19) из терминала Linux

gridcoin_boinc
Хочу спросить не о тех вирусах! Побродил firefox по порносайтам и кажется поймал вирус,в операционной системе ubuntu 18.04
файловой системе ext4! У меня еще установлена Linux mint 19.3 с файловой системой Lvm2 pv, на ней я вирусы не ловил!
Вопрос: веб firefox ненадежный? Или система Lvm2 более надежная? Или надо устанавливать антивирус?

Ответить | Древовидный
Открыть эту статью в виде дерева
|

Re: Corona-cli - отслеживание статистики коронавируса (COVID-19) из терминала Linux

Админ
Администратор
--Побродил firefox по порносайтам и кажется поймал вирус,в операционной системе ubuntu 18.04 --
1. Не бродите по порносайтам.
2. Как Вы определили, что firefox поймал вирус?
Ответить | Древовидный
Открыть эту статью в виде дерева
|

Re: Corona-cli - отслеживание статистики коронавируса (COVID-19) из терминала Linux

gridcoin_boinc
Порносайты боятся, в лес не ходить! :)
PC вдруг начал тормозить, перезагрузил,поднимался минут 5! Мышка и клава не реагирует, а на рабочем столе иконки подписаны аброй-кадаброй!
Я отформатировал раздел Ubuntu, и использую Linux-mint! Заметил что Ubuntu и Linux-mint используют разную файловую систему!



Ответить | Древовидный
Открыть эту статью в виде дерева
|

Re: Corona-cli - отслеживание статистики коронавируса (COVID-19) из терминала Linux

Админ
Администратор
== Заметил что Ubuntu и Linux Mint используют разную файловую систему!==
Как это? Ведь вовремя установки Вы указывали файловую систему и в Ubuntu, и в Linux Mint или как?
А для таких случаев есть в Linux очень хороший инструмент -Timeshift. Посредством которого можно делать снимки и восстановление системы.
Переустановите систему, настройте её и сделайте бэкап с Timeshift. И всё. Все вопросы отпадут сами собой.
Ответить | Древовидный
Открыть эту статью в виде дерева
|

Re: Corona-cli - отслеживание статистики коронавируса (COVID-19) из терминала Linux

gridcoin_boinc
Устанавливал давно,не помню чтобы при установке спрашивали какую файловую систему выбрать!
Недавно устанавливал для изучения MX Linux, так там установшик спрашивал: шифровать файловую систему? И я подумал,что зашифрованный диск будет медленнее работать! Спасибо, теперь делаю бэкап!
Вопрос:Вирусы не страшны, если зашифровать файловую систему?
Ответить | Древовидный
Открыть эту статью в виде дерева
|

Re: Corona-cli - отслеживание статистики коронавируса (COVID-19) из терминала Linux

Админ
Администратор
==Устанавливал давно,не помню чтобы при установке спрашивали какую файловую систему выбрать! ==
Так вот когда во время установки нужно указать файловую систему в Ubuntu.

Ответить | Древовидный
Открыть эту статью в виде дерева
|

Re: Corona-cli - отслеживание статистики коронавируса (COVID-19) из терминала Linux

muscovite
Вроде бы, казалось, всего три буквы - одна не та, второй и третьей вообще нет... Зато как меняется смысл предложения... )))
Ответить | Древовидный
Открыть эту статью в виде дерева
|

Re: Corona-cli - отслеживание статистики коронавируса (COVID-19) из терминала Linux

Джо Неуловимый
В ответ на это сообщение от gridcoin_boinc
gridcoin_boinc написал
 Побродил firefox по порносайтам и кажется поймал вируc
Порнхаба хватит всем. Тем более, что они сейчас премиум всем бесплатно на период пандемии раздают. :)
Ответить | Древовидный
Открыть эту статью в виде дерева
|

Re: Corona-cli - отслеживание статистики коронавируса (COVID-19) из терминала Linux

Владимир Задорожнюк
В ответ на это сообщение от gridcoin_boinc
Это вообще возможно, вирус в linux, через просмотр в браузере, и крякнул систему, может нужно проверить hdd для  начала:)
Ответить | Древовидный
Открыть эту статью в виде дерева
|

Re: Corona-cli - отслеживание статистики коронавируса (COVID-19) из терминала Linux

gridcoin_boinc
Проверил hdd, в идеальном состоянии! Отформатировал диск и перевел в формат lvm2 pv
Что то подсказывает мне что вирус или вирусы или черви были написаны специально для ехт4
А вы не стесняйтесь побродите по порносайтам, совершите эксперимент!
Ответить | Древовидный
Открыть эту статью в виде дерева
|

Re: Corona-cli - отслеживание статистики коронавируса (COVID-19) из терминала Linux

Владимир Задорожнюк
Так и не стесняюсь, правда стоит системный  фаервол, а в браузерах расширение adguard или подобное ему, рекламы, как таковой, нету, даже в ютубе, можете и себе поставить, если что
Ответить | Древовидный
Открыть эту статью в виде дерева
|

Re: Corona-cli - отслеживание статистики коронавируса (COVID-19) из терминала Linux

AlexandrS
В ответ на это сообщение от Админ
Установка данной програмы в Ubuntu 18.04.3 LTS весьма проблематична так как ;

root@alexandr-System-Product-Name:/home/alexandr/Загрузки# dpkg -i npm_3.5.2-0ubuntu4_all.deb
Выбор ранее не выбранного пакета npm.
(Чтение базы данных … на данный момент установлено 236639 файлов и каталогов.)
Подготовка к распаковке npm_3.5.2-0ubuntu4_all.deb …
Распаковывается npm (3.5.2-0ubuntu4) …
dpkg: зависимости пакетов не позволяют настроить пакет npm:
 npm зависит от node-abbrev (>= 1.0.4), однако:
  Пакет node-abbrev не установлен.
 npm зависит от node-ansi (>= 0.3.0-2), однако:
  Пакет node-ansi не установлен.
 npm зависит от node-ansi-color-table, однако:
  Пакет node-ansi-color-table не установлен.
 npm зависит от node-archy, однако:
  Пакет node-archy не установлен.
 npm зависит от node-block-stream, однако:
  Пакет node-block-stream не установлен.
 npm зависит от node-fstream (>= 0.1.22), однако:
  Пакет node-fstream не установлен.
 npm зависит от node-fstream-ignore, однако:
  Пакет node-fstream-ignore не установлен.
 npm зависит от node-github-url-from-git, однако:
  Пакет node-github-url-from-git не установлен.
 npm зависит от node-glob (>= 3.1.21), однако:
  Пакет node-glob не установлен.
 npm зависит от node-graceful-fs (>= 2.0.0), однако:
  Пакет node-graceful-fs не установлен.
 npm зависит от node-inherits, однако:
  Пакет node-inherits не установлен.
 npm зависит от node-ini (>= 1.1.0), однако:
  Пакет node-ini не установлен.
 npm зависит от node-lockfile, однако:
  Пакет node-lockfile не установлен.
 npm зависит от node-lru-cache (>= 2.3.0), однако:
  Пакет node-lru-cache не установлен.
 npm зависит от node-minimatch (>= 0.2.11), однако:
  Пакет node-minimatch не установлен.
 npm зависит от node-mkdirp (>= 0.3.3), однако:
  Пакет node-mkdirp не установлен.
 npm зависит от node-gyp (>= 0.10.9), однако:
  Пакет node-gyp не установлен.
 npm зависит от node-nopt (>= 3.0.1), однако:
  Пакет node-nopt не установлен.
 npm зависит от node-npmlog, однако:
  Пакет node-npmlog не установлен.
 npm зависит от node-once, однако:
  Пакет node-once не установлен.
 npm зависит от node-osenv, однако:
  Пакет node-osenv не установлен.
 npm зависит от node-read, однако:
  Пакет node-read не установлен.
 npm зависит от node-read-package-json (>= 1.1.0), однако:
  Пакет node-read-package-json не установлен.
 npm зависит от node-request (>= 2.25.0), однако:
  Пакет node-request не установлен.
 npm зависит от node-retry, однако:
  Пакет node-retry не установлен.
 npm зависит от node-rimraf (>= 2.2.2), однако:
  Пакет node-rimraf не установлен.
 npm зависит от node-semver (>= 2.1.0), однако:
  Пакет node-semver не установлен.
 npm зависит от node-sha, однако:
  Пакет node-sha не установлен.
 npm зависит от node-slide, однако:
  Пакет node-slide не установлен.
 npm зависит от node-tar (>= 0.1.18), однако:
  Пакет node-tar не установлен.
 npm зависит от node-underscore, однако:
  Пакет node-underscore не установлен.
 npm зависит от node-which, однако:
  Пакет node-which не установлен.
Ответить | Древовидный
Открыть эту статью в виде дерева
|

Re: Corona-cli - отслеживание статистики коронавируса (COVID-19) из терминала Linux

Админ
Администратор
AlexandrS, в статье в самом начале есть указание на установку Node.js .
"Прежде чем устанавливать Corona-cli, у вас должен быть установлен Node.js для вашей ОС."
Ответить | Древовидный
Открыть эту статью в виде дерева
|

Re: Corona-cli - отслеживание статистики коронавируса (COVID-19) из терминала Linux

zelinograd
Приветствую. У меня debian 10. Установился нормально пакет nodejs, а corona-cli почему-то не устанавливается:  "sudo npm install -g corona-cli
sudo: npm: command not found"  Пробовал и доугую команду "sudo npx corona-cli" Результат тот же.
Вместо npm написал apt -  не помогло. Помогите пожалуйста.
Ответить | Древовидный
Открыть эту статью в виде дерева
|

Re: Corona-cli - отслеживание статистики коронавируса (COVID-19) из терминала Linux

in-tensive
Владимир, спасибо за прекрасную находку. Очень актуально в наши дни.

Для тех у кого не устанавливается:

Для работы программы необходимы библиотеки Node.Js.
Если перейти по ссылке из статьи на официальный сайт можно получить крайне неудобную инструкцию по установке, которая переправляет на GitHub. А GitHub нужно читать.

С разрешения автора статьи опубликую установку Node.Js v.13 для Ubuntu и Debian - это работает.


Ubuntu:

curl -sL https://deb.nodesource.com/setup_13.x | sudo -E bash -
sudo apt-get install -y nodejs

Debian - ставить от "root":

curl -sL https://deb.nodesource.com/setup_13.x | bash -
apt-get install -y nodejs


Потом уже можно выполнить команду из статьи:

sudo npm install -g corona-cli
Ответить | Древовидный
Открыть эту статью в виде дерева
|

Re: Corona-cli - отслеживание статистики коронавируса (COVID-19) из терминала Linux

sasha
В ответ на это сообщение от Админ
Я слежу за коронавирусом на сайте: https://gisanddata.maps.arcgis.com/apps/opsdashboard/index.html#/bda7594740fd40299423467b48e9ecf6
Ответить | Древовидный
Открыть эту статью в виде дерева
|

Re: Corona-cli - отслеживание статистики коронавируса (COVID-19) из терминала Linux

zelinograd
В ответ на это сообщение от in-tensive
Всё равно ничего не получается:
root@debian:/home/sergey# curl -sL https://deb.nodesource.com/setup_13.x | bash -
bash: curl: команда не найдена
root@debian:/home/sergey# apt-get install -y nodejs
Чтение списков пакетов… Готово
Построение дерева зависимостей      
Чтение информации о состоянии… Готово
Уже установлен пакет nodejs самой новой версии (10.15.2~dfsg-2).
Обновлено 0 пакетов, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
Как быть?
Ответить | Древовидный
Открыть эту статью в виде дерева
|

Re: Corona-cli - отслеживание статистики коронавируса (COVID-19) из терминала Linux

in-tensive
curl - это тоже программный пакет. Может он у вас просто не установлен? Проверьте.
Устанавливается через "sudo apt install curl"

Плюс, если у Вас Debian - выполнять установку "corona" нужно через sudo, то есть

sudo curl -sL... и так далее

На GitHub для Debian написано в оригинале вот так:

# Using Debian, as root
curl -sL https://deb.nodesource.com/setup_13.x | bash -
apt-get install -y nodejs

Ссылка: https://github.com/nodesource/distributions/blob/master/README.md
Ответить | Древовидный
Открыть эту статью в виде дерева
|

Re: Corona-cli - отслеживание статистики коронавируса (COVID-19) из терминала Linux

VladimirT
Ребята у кого Debian 10:
1- установить в synaptic: npm (установится много пакетов)
2- а теперь: sudo npm install -g corona-cli
Вот и всё:) Всем удачи :)
12